Tag Archives: code signing

NativeScript: iOS xCode 7.2+ Code signing fix!

For the last couple months since xCode 7.2 was released, those poor iOS developers who upgraded to 7.2 have felt much pain if they installed any Cocoapods. If you didn't use any PODs you were fine.  But the minute you used a plugin that has a POD; you were in for a world of hurt.  And this error: CodeSign error: entitlements are required for product type 'Application' in SDK 'Simulator - iOS 9.2'. Your Xcode installation may be damaged.  Was our only clue to what was wrong, not very helpful since Simulator apps aren't supposed to be signed.

The solutions that I handed out was to either to de-install and downgrade to 7.1 or to  build the app inside of the xCode environment.  Neither were great solutions.

I saw the solution appear a couple days ago in the issues; and finally had time to upgrade my environment back up to 7.2.1 to test and verify before I spread the good news.

I can't take credit for the fix, that goes to Ivan & Dimitar at Telerik who figured out why those using xCode 7.2+ could no longer use the TNS command line to build our applications.   The fixes will be showing up in the new v1.6 which should be released any day now; but in the meantime I figured I would document the fix so that you can apply it to your projects now.  And unless you are planning on uninstalling the iOS runtimes and install them again in v1.6; you will still have to manually apply this fix to any existing projects.

xcode-Fix-1So lets say your app is named: MyAwesomeApp.   You need to navigate to your MyAwesomeApp/ platforms / ios / MyAwesomeApp / folder and then edit the build.xcconfig file. In the picture above the app is called crossCommunicator; so you will see that the path for the file for my app is crossCommunicator / platforms / ios / crossCommunicator / build.xcconfig.

Open that file up and then you should see something like this:

xcode-Fix-2You see that line that says:
CODE_SIGN_IDENTITY = iPhone Developer?
Comment it out, so that it now says:
// CODE_SIGN_IDENTITY = iPhone Developer

xcode-Fix-3

Save the file, and you are all set to go!   You can now use xCode 7.2+ and Cocoapods fine!